BeatStars

Support centerSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Potential content downloading issue
Resolved·Degraded performance

The potential content downloading issue was resolved on 20th July.

Fri, Jul 24, 2026, 03:10 PM
(2 months ago)
·
Affected components
Jul 20, 2026, 02:46 PM
03:10 PM
Audio
Updates

Resolved

The potential content downloading issue was resolved on 20th July.

Fri, Jul 24, 2026, 03:10 PM

Investigating

Potential content downloading issue

Mon, Jul 20, 2026, 02:46 PM(4 days earlier)