Creator Rights Agency may be inaccessible due to 3rd-party outage

Incident Report for BeatStars

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 16:25 UTC

Update

We are continuing to work on a fix for this issue.
Posted Nov 18, 2025 - 15:17 UTC

Identified

There is an issue with a third-party service that is impacting users' ability to access the Creator Rights Agency portal. Once this is resolved, we will update users.
Posted Nov 18, 2025 - 15:16 UTC