Unable to Withdraw from Wallet

Incident Report for BeatStars

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 01:14 UTC

Investigating

We are currently investigating an issue where users are unable to withdraw funds from their wallet. While you cannot withdraw at this time, there is no negative impact to your funds.
Posted Mar 30, 2026 - 18:18 UTC
This incident affected: Studio (Publishing).