Potential content purchasing issue

Incident Report for BeatStars

Resolved

This incident has been resolved.
Posted Sep 13, 2023 - 14:57 UTC

Investigating

We are currently investigating this issue.
Posted Sep 13, 2023 - 14:12 UTC