PayPal is currently experiencing an issue that is impacting BeatStars
Incident Report for BeatStars
Resolved
This incident has been resolved.
Posted Oct 16, 2024 - 23:11 UTC
Monitoring
Currently, PayPal is experiencing an issue that is impacting BeatStars. Sellers may see errors related to their PayPal payout method, and Buyers may be unable to complete purchases. At this time, we are monitoring PayPal's status here: https://www.paypal-status.com/product/production

We hope the issue is resolved quickly.
Posted Oct 16, 2024 - 20:00 UTC
This incident affected: Marketplace (Main Service) and Studio (Main Service).