Android Renewal Subscription Minor Issue
Incident Report for BeatStars
Resolved
This incident has been resolved.
Posted May 26, 2023 - 21:47 UTC
Identified
We have identified the issue and are working on a fix. We apologize for any inconvenience and appreciate your patience while we work to restore normal service.

Updates to follow.
Posted May 26, 2023 - 16:55 UTC
Update
We have identified the issue and are working on a fix. We apologize for any inconvenience and appreciate your patience while we work to restore normal service.

Updates to follow.
Posted May 25, 2023 - 19:47 UTC
Update
We are aware of current service issues and are investigating. We apologize for any inconvenience and appreciate your patience while we work to resolve the issue.
Updates to follow.
Posted May 25, 2023 - 17:45 UTC
Update
We are aware of current service issues and are investigating. We apologize for any inconvenience and appreciate your patience while we work to resolve the issue.
Updates to follow.
Posted May 25, 2023 - 14:46 UTC
Update
We are aware of current service issues and are investigating. We apologize for any inconvenience and appreciate your patience while we work to resolve the issue.
Updates to follow.
Posted May 25, 2023 - 13:24 UTC
Update
We are aware of current service issues and are investigating. We apologize for any inconvenience and appreciate your patience while we work to resolve the issue.
Updates to follow.
Posted May 25, 2023 - 12:28 UTC
Investigating
We are currently investigating this issue.
Posted May 25, 2023 - 12:00 UTC