Potential sign up issue
Incident Report for BeatStars
Resolved
This incident has been resolved.
Posted Aug 27, 2023 - 20:05 UTC
Investigating
We are currently investigating this issue.
Posted Aug 27, 2023 - 20:05 UTC