Potential content purchasing issue

Incident Report for BeatStars

Resolved

This incident has been resolved.
Posted Jan 01, 2025 - 17:52 UTC

Investigating

We are currently investigating this issue.
Posted Jan 01, 2025 - 17:13 UTC