Potential content purchasing issue

Incident Report for BeatStars

Resolved

This incident has been resolved.
Posted Dec 31, 2023 - 21:29 UTC

Investigating

Potential content purchasing issue
Posted Dec 31, 2023 - 17:08 UTC