Purchases may not be working

Incident Report for BeatStars

Resolved

This incident has been resolved.
Posted May 06, 2026 - 13:47 UTC

Investigating

Purchases may be failing, preventing users completing orders or unable to access beats after successful payments.
Posted May 06, 2026 - 13:47 UTC