Degraded Performance due to Amazon Web Services Issues

Incident Report for BeatStars

Resolved

AWS has resolved their issues, and all our systems are back to functioning normally as a result.
Posted Oct 21, 2025 - 11:36 UTC

Identified

Amazon Web Services is experiencing a global outage that is impacting the BeatStars platform. Users may experience degraded performance such as slow load times, long waits to receive emails or notifications, and intermittent issues logging in, among other issues. Our status page will automatically update to reflect any changes to the services we use. We appreciate your patience and understanding.
Posted Oct 20, 2025 - 13:23 UTC